Introducing: PS4 FPKG Enabler for PS5 4.03, Developed by Sleirsgoevy


Screenshot of functional PS4 FPKG on PS5, by Echo Stretch

Following the recent fpkg-related commits to his PS5 hacks repository, Sleirsgoevy has released PS4 FPKG Support for the PS5, as a “fpkg enabler” payload for the PS5. In other words, PS4 game “backups” are now a possibility on the PS5.

The PS5 can now run PS4 game “backups”

Thanks to work by Sleirsgoevy over the past few weeks, PS4 fpkg support has been fully implemented on hacked PS5. Multiple people have confirmed the release does work, although some apps and games might crash, or not load properly. Modded Warfare has confirmed that some PS1 and PS2 games (packaged for the PS4) also work.

It is also worth mentioning that these release only works on firmware 4.03, due to some hardcoded offsets (specific to that firmware) used in the mechanism.

Should you update your PS5 to 4.03?

Although a lot of hackers are working exclusively on PS5 4.03, and this impressive release is only compatible with that firmware for the time being, I personally wouldn’t recommend updating to 4.03 if you’re on a lower firmware (well, 4.02 might be the exception here).

For now, all 4.03 would give you is the possibility to run PS4 game backups, something that is already possible, and in better conditions, on a hacked PS4. Although the PS5 does give a performance boost to most PS4 games, in its current state, the hack is reported to crash quite often, and not work with all games yet.

Check new:   Next Week, Target's Buy 2 Get 1 Free Sale on Video Games Begins

This is not to say that this features will come to lower PS5 Firmwares any time soon. A lot of the work done by Sleirsgoevy is very specific to 4.03, in particular with lots of hardcoded offsets that are “difficult” to find for other firmwares.

Download and test: PS4 FPKG Support on PS5

As a reminder, you will need a PS5 running firmware 4.03 to run this payload.

You can Download the payload here. You might need to use Sleirsgoevy’s version of the PS5 exploit (e.g. his version of the webkit exploit) though. Last time I checked, his payload format isn’t compatible with the version that is most commonly used, based on SpecterDev’s code.

The source code can be found on Sleirsgoevy’s github.

Echo Stretch has a “how to” video here:

Source: via Zecoxao



Source